Error "Cannot update from v4.5 to v4.6 directly. Please uninstall version 4.5 and then install 4.6."

Save to PDF

Applies to: Cloudhouse Compatibility Containers, Container Editor

10/06/2019 Cliff Hobbs   ID: 390961

Symptoms

When trying to update an existing Cloudhouse Compatibility Containerâ„¢ from version 4.5 to version 4.6, the following error is displayed:

Cannot update from v4.5 to v4.6 directly. Please uninstall version 4.5 and then install 4.6.

Cause

This is normal functionality. Version 4.6 of the Cloudhouse components use different GUID virtualisation compared to version 4.5. It is therefore unsupported for a Container that uses version 4.6 components to use the Container -Update switch to update a v4.5 Container that has already been deployed as this would leave behind items in the Registry.

Resolution

To fix this issue, uninstall version 4.5.x of the Container Editor and install version 4.6.1903.1001 or later.

Source:
Was this article helpful?

Table of Contents

    Can't find what you're looking for?

    Contact Support